errore MySql 2002   facebook   twitter   google+

Discussioni su PHP, Apache e MySQL

Moderatore: spacemarc

Rispondi
Teodoro71
Membro junior
Messaggi: 4
Iscritto il: 13 ago 2011, 10:54

errore MySql 2002

Messaggio da Teodoro71 » 13 ago 2011, 11:19

Buongiorno, non riesco ad installare lo script poichè mi restituisce un errore che qui vi riporto:

Codice: Seleziona tutto

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /web/htdocs/www.orologi-storici-italia.org/home/news/install/install.php on line 18
Impossibile connettersi a MySQL
Numero errore: 2002
Tipo di errore: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
Non essendomi mai capitato un errore simile non saprei cosa devo guardare/attenzionare, anche perchè ho provato a fare l'unica cosa possibile che m'è venuta in mente, cambiare i due riferimenti a Db User e Nome DB, ma restituisce sempre quell'errore.

Alcuni dati, forse utili: (eventualmente servisse posso reperire dati che servono...)

Maintainer: Aruba
Server: Linux
Php versione: 5.2.17
MySql Versione: 5.0.92-enterprise-gpl-log

Consigli, suggerimenti ?

Grazie di cuore per l'aiuto

Teodoro

Avatar utente
spacemarc
Amministratore
Messaggi: 1076
Iscritto il: 22 giu 2002, 15:16
Località: Italia
Contatta:

Re: errore MySql 2002

Messaggio da spacemarc » 17 ago 2011, 13:33

l'errore 2002 indica che il server MySQL non è in esecuzione
spacemarc.it

Teodoro71
Membro junior
Messaggi: 4
Iscritto il: 13 ago 2011, 10:54

Re: errore MySql 2002

Messaggio da Teodoro71 » 18 ago 2011, 1:30

Oibò..molto strano perchè ho installato l'ultima versione di wordpress per fare degli esperimenti e funge.
Uhm, ri-provo e vediamo se và.
In realtà io ho ben idea di come vorrei fare il mio sito e il tuop script andrebbe davvero a pennello :-)

Grazie e a rileggerci presto

Teodooro

Teodoro71
Membro junior
Messaggi: 4
Iscritto il: 13 ago 2011, 10:54

Re: errore MySql 2002

Messaggio da Teodoro71 » 18 ago 2011, 10:50

Non so se sia un mio problema, ma ho riscontrato queste difficoltà nell'uso dello script:

1) Non mi visualizza immagini inserite tramite il pulsante dell'editor "img". Non genera il codice nella notizia

2) Non visualizza filmati da You Tube, come sopra: se scelgo dalle funzioni dell'editor la voce "video" e poi inserisco l'URL del video da caricare, nella pagina NON compare nessun riferimento al codice e quindi nemmeno il video che vorrei inserire

3) Non mi permette di modificare immagini inserite in precedenza: quando vado su "sfoglia" e seleziono dal mio PC l'immagine da caricare, mi accorgo che non c'è più la dicitura a fianco con scritto "inserisci"

4) Non mi permette di caricare allegati in pdf: se vado su sfoglia e poi cerco di caricare qualsiasi file, lo script continua ad inserirmi il file che ha nella cartella "Upload" ignorando completamente la risorsa che vorrei inserire.

Ho notato che non è abilitato l'HTML.
S.O. Windows XP SE
Browser: Mozzilla Firefox

Suggerimenti, idee son ben accetti :tongue:

Un caro saluto
Teodoro

Ps: spero di essermi spiegato al meglio, eventualmente chiedetemi maggiori dettagli o screenshot

Teodoro71
Membro junior
Messaggi: 4
Iscritto il: 13 ago 2011, 10:54

Re: errore MySql 2002

Messaggio da Teodoro71 » 18 ago 2011, 10:52

spacemarc ha scritto:l'errore 2002 indica che il server MySQL non è in esecuzione
Ok, risolto: SE siete su Aruba ed avete attivato il servizio MySql, dovete inserire nel file config.php al posto di "localhost" il vostro riferimento al DB (esempio: 123 456 789 ) il riferimento lo trovate nella e-mail di conferma attivazione o quando accedete al pannello del vostro DB.

Teodoro

Avatar utente
spacemarc
Amministratore
Messaggi: 1076
Iscritto il: 22 giu 2002, 15:16
Località: Italia
Contatta:

Re: errore MySql 2002

Messaggio da spacemarc » 18 ago 2011, 11:32

Teodoro71 ha scritto: 1) Non mi visualizza immagini inserite tramite il pulsante dell'editor "img". Non genera il codice nella notizia
devi inserire il percorso assoluto: http://www.sito.tld/foto.jpg
Teodoro71 ha scritto: 2) Non visualizza filmati da You Tube, come sopra: se scelgo dalle funzioni dell'editor la voce "video" e poi inserisco l'URL del video da caricare, nella pagina NON compare nessun riferimento al codice e quindi nemmeno il video che vorrei inserire
devi inserire solo l'identificativo del video (quello composto da 11 caratteri), non il suo URL: esempio [yt]5IfHm6R5le0[/yt]
Teodoro71 ha scritto: 3) Non mi permette di modificare immagini inserite in precedenza: quando vado su "sfoglia" e seleziono dal mio PC l'immagine da caricare, mi accorgo che non c'è più la dicitura a fianco con scritto "inserisci"
quando fai l'upload di un'immagine (o altro file) devi cliccare su Anteprima (o Inserisci): vedrai così due link di fianco che ti permetteranno di inserire il file nel testo o di visualizzarlo.
Teodoro71 ha scritto: 4) Non mi permette di caricare allegati in pdf: se vado su sfoglia e poi cerco di caricare qualsiasi file, lo script continua ad inserirmi il file che ha nella cartella "Upload" ignorando completamente la risorsa che vorrei inserire.
come sopra: selezioni il file e clicchi su Anteprima (o Inserisci). O forse è un problema di mime-type? a volte i browser riconoscono un file in maniera diversa. Prova con un altro browser e fammi sapere.
Teodoro71 ha scritto:Ho notato che non è abilitato l'HTML.
Esatto: se un utente non esperto cominciasse ad inserire codice html non valido potrebbero esserci dei problemi, sia di sicurezza per il server che di layout col resto del sito. Apposta ci sono i bbCode che per formattare il testo sono più che sufficienti.
spacemarc.it

Rispondi